v3.4 HARD FORK

Mandatory v3.4.0 patch has been released, and everyone is required to upgrade their wallet by August 30 2019 @ 16:00 GMT to stay on the correct chain. Please upgrade as soon as possible.

Wordpress Social Share Plugin powered by Ultimatelysocial