Estimada comunidad PIVX, somos plenamente conscientes del recientemente mencionado “exploit” (vulnerabilidad en el código) de libzerocoin (librería que del protocolo zerocoin). Un “exploiter” (persona que usa el exploit en su beneficio) fue capaz de crear múltiples pruebas para una sola transacción (proofs for a single mint), creando así múltiples series, que entonces él o ella, consiguió convertirlas a PIV. Este exploit se encuentra en el código base de la biblioteca de libzerocoin, que se utiliza también en muchas otras monedas y no sólo en el código de PIVX. NINGÚN usuario ha perdido sus fondos. Los Exchanges (casas de cambio) ya han sido notificadas. Mientras tanto puedes continuar usando la Wallet $PIVX 3.0.4, liberaremos un parche de seguridad para corregir el problema en todas las plataformas. Adicionalmente, Zerocoin está temporalmente desactivado hasta que sea completamente corregido. Lamentamos el inconveniente, pero es para tu seguridad y para la estabilidad de la red”.

 

~El PIVX Dev Team

*¡LLAMADA A LAS ARMAS! ESPECIALMENTE PARA LOS QUE HACEN STAKE*

Se encontró un nuevo exploit en el código fuente original de libzerocoin que condujo a una vulnerabilidad en zPIV minting.

Puedes consultar el anuncio oficial sobre la situación del exploit aquí: https://pivx.org/from-the-dev-team/

Para resolver este problema, necesitamos la ayuda de todos los usuarios de wallets (billeteras) de escritorio para reorganizar la red a la cadena correcta (good chain), corregida ya sin el exploit.

 

– Si puedes apoyarnos, realmente estarías ayudando a la red y además se bloquearía cualquier nuevo intento de ataque.

– Si prefieres esperar al lanzamiento final de la billetera (wallet) corregida, entonces se recomienda cerrar la billetera por el momento.

– Tus monedas están 100% seguras. Pero el “zPIV mint/spend” se desactivarán temporalmente para detener cualquier nuevo exploit.

– Esperamos tener una billetera corregida en los próximos días, una vez que consigamos que la red y las billeteras sean seguras contra el exploit.

*INSTRUCCIONES*

ADVERTENCIA: Si no deseas participar en este “lanzamiento temporal”, cierre la Wallet y espere el lanzamiento oficial.

 

  1. Cierra / Desconecta completamente tu Wallet (cartera) actual.
  2. Descarga la nueva versión ya corregida al exploit ‘pre-release 3.0.99’ (vtemp_dev) https://github.com/PIVX-Project/PIVX/releases/tag/vtemp_dev  (puedes consultar las notas de la versión)
  3. Edita el archivo ‘pivx.conf’ y anexa las siguientes líneas al final del mismo

(Para localización de este archivo, puedes consultar: https://pivx.freshdesk.com/support/solutions/articles/30000004664)

enablezeromint=0

addnode=24.10.252.146

addnode=67.188.76.36

addnode=70.189.238.111

addnode=104.200.67.38

addnode=74.118.192.18

banscore=10000

bantime=5

  1. Borra el archivo ‘peers.dat’ que se encuentra localizado en la misma carpeta que ‘pivx.conf’
  2. Abre tu Wallet y espera hasta que la sincronización termine.
  3. Ahora verifica si estás en la cadena correcta. Puedes consultar las instrucciones están aquí: https://pivx.freshdesk.com/solution/articles/30000004667
  4. Si no estás en el mismo ‘block:hash que el explorador presstab, realiza un reindex.

Qt Wallet = Herramientas -> Reparación de la Wallet -> Reparar Monedero -> Reconstruir índice (esto puede demorar varios minutos)

Linux = Cerrar la billetera. Comience la billetera con ‘-reindex = 1′ (ejemplo:’ ./pivxd -reindex = 1′)

7.- Si todo se ve bien, desbloquea para hacer staking, si normalmente haces stake con tus monedas.

‘El stake es seguro con esta versión ‘pre-release’ Wallet. La advertencia es solo genérica.

¡Muchas gracias!